Generated Hash not rendering

Jul 11, 2012 at 9:02 PM

Hello!

I found this project and have begun to try and implement it on my website, I have it so it generates the css tag with the Hash alias, and have debugged the code and view the contents of the BundleTable, and it has been correctly formated.

 

in Global.asaz.cs

 

var css = new Bundle("~/css", typeof(CssMinify));           

css.AddFile("~/css/anythingslider.css");           

css.AddFile("~/css/anythingslider-ie.css");           

css.AddFile("~/css/base.css");           

css.AddFile("~/css/skeleton.css");           

css.AddFile("~/css/layout.css");           

css.AddFile("~/css/content-styles.css");           

BundleTable.Add(css);

 

in the custom macro

<link href="@BundleTable.ResolveUrl("~/css")" rel="stylesheet" type="text/css" />

 

whats rendered on page,

<link href="/-954238933" rel="stylesheet" type="text/css" />

 

Any suggestion to what needs to be added, changed or fixed?

 

Coordinator
Jul 11, 2012 at 9:29 PM
Edited Jul 11, 2012 at 9:30 PM

Hi David.

/-954238933 is the hash for the content. Do you mean there is no content? (the request for /-954238933 returns a 404?) If so you probably forgot to add the HTTP module to your config. Also make sure it is added to the right section. In II7 and IIS Express it goes in the system.webServer modules section and in IIS6 and Cassini it goes in system.web httpModules section.

Jul 11, 2012 at 10:03 PM

Thank you for your quick response, I added the two sections to the correct areas of the web.config:

 

<system.web>

       <httpModules>

                <add name="BundleModule" type="Bundler.BundleModule, Bundler" />

And

<system.webServer>  

       <modules runAllManagedModulesForAllRequests="true">

               <add name="BundleModule" type="Bundler.BundleModule, Bundler" />

 

I may be trying to access this wrong, the link when click redirects to the same page it was on. Is there a way to try and view the cached copy of the css or js to ensure its being saved correctly?